Solved – “the version of iphoto installed on this mac must be updated through the mac app store”

Posted by in Computer Repairs & Troubleshooting | 0 comments

I was recently helping a client who had lost access to his iphoto through an update to osx mavericks (and also sierra, which removes iphoto altogether) and it wouldn’t launch due to that version not being compatible with the OSX. When I found an update to iphoto it also wouldn’t install due to the mac thinking it was linked to an app store account. Fortunately I found this awesome workaround if you are comfortable working with the console in osx;

 

sudo rm -r /Applications/iPhoto.app/Contents/_MASReceipt

 

hopefully this will help anyone else with this same error: the version of iphoto installed on this mac must be updated through the mac app store. This solution was found here; https://acdesigntech.wordpress.com/2013/03/06/disable-mac-app-store-receipts-to-reenable-downloaded-update-packages/ thanks for sharing it guys!

also I found these individual links for iphoto upgrades;

 

1 – update to iPhoto 9.2.1

2 – update to iPhoto 9.3

3 – update to iPhoto 9.3.2

4 – update to iPhoto 9.4

5 – and finally to iPhoto 9.4.3

Leave a Reply

Your email address will not be published. Required fields are marked *